Canvas Page Errors in SpeedGrader and Files
Incident Report for Canvas at Penn
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 12:33 EDT
Identified
Canvas users are receiving "Service is currently unavailable. Try again later" errors in SpeedGrader, as well as links to Files.

The vendor is working on a fix for the issue.

For more information, please see: https://status.instructure.com/incidents/dbmjkkx8qycm
Posted Apr 28, 2022 - 11:44 EDT
This incident affected: Canvas.