SpeedGrader slow to respond or page errors
Incident Report for Canvas at Penn
Resolved
This incident has been resolved.

We recommend logging out of Canvas and clearing your browser cache. If you continue to experience problems, please contact canvas@pobox.upenn.edu.
Posted May 13, 2022 - 12:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 11:54 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 13, 2022 - 10:50 EDT
Investigating
SpeedGrader may be extremely slow to respond or produce errors of “Service is currently unavailable. Try again later.”

This issue has been reported to the vendor and they are working to resolve it as soon as possible. We apologize for any inconvenience this issue may be causing.
Posted May 13, 2022 - 10:03 EDT
This incident affected: Canvas.