Turnitin Issues- 5/4

Incident Report for Canvas at Penn

Resolved

This issue has been resolved. Please note that Canvas will resubmit the affected submissions; it is worth noting that this may take a while to complete.
Posted May 04, 2026 - 19:01 EDT

Identified

Users may encounter errors accessing or generating reports in Turnitin. For updates please see the vendor's status page: https://turnitin.statuspage.io/

Canvas and all other integrated tools are available and working normally.

Please direct any questions to canvas@pobox.upenn.edu
Posted May 04, 2026 - 12:14 EDT
This incident affected: Learning Tools (Turnitin).