Access to Penn Canvas has been restored. Please report any continuing issues to canvas@pobox.uepnn.edu
Posted May 08, 2026 - 08:09 EDT
Update
Penn Canvas is still inaccessible this morning due to problems with authentication. We are working with ISC and Instructure to resolve this as soon as soon as possible.
Posted May 08, 2026 - 07:12 EDT
Update
Penn Canvas is still unavailable at this time. Please see the vendor's status page for updates: https://status.instructure.com/