Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 07, 2026 - 11:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 04, 2026 - 13:13 EST
Scheduled
On Saturday, March 7 from 11am-3pm Eastern:
Turnitin may be unavailable due to scheduled maintenance by the vendor. - Only assignments using the Turnitin originality checking settings ("Plagiarism Review") will be affected. - To avoid issues, instructors are encouraged to set due dates for Turnitin assignments outside of the scheduled maintenance window. - Students are encouraged to submit Turnitin assignments in advance of affected due dates.
Some Gradescope features (Exporting submissions & submitting files for Code Similarity Reports) will be unavailable. All other components of Gradescope will be operational.
Canvas and all other integrated tools will be available and unaffected by this maintenance.