Canvas Outage
Incident Report for Canvas at Penn
Resolved
This issue should be resolved. Please report any continued problems accessing or using Canvas to canvas@pobox.upenn.edu
Posted Sep 21, 2022 - 15:30 EDT
Monitoring
Instructure has implemented a fix and is monitoring the results.
Posted Sep 21, 2022 - 14:43 EDT
Investigating
Instructure is reporting a significant outage of Canvas that is impacting both the Penn Canvas and Open Canvas environments.

Updates are being posted to: https://status.instructure.com/
Posted Sep 21, 2022 - 14:27 EDT
This incident affected: Canvas.