AWS Outage (Canvas, Gradescope, Turnitin, iThenticate)

Incident Report for Canvas at Penn

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:04 EDT

Update

This incident has been resolved by the vendor.

Please report any continuing Canvas issues to canvas@pobox.upenn.edu
Posted Oct 20, 2025 - 21:03 EDT

Monitoring

Canvas access has been restored and the vendor is monitoring to ensure stability.

Please report any continuing issues to canvas@pobox.upenn.edu
Posted Oct 20, 2025 - 19:53 EDT

Update

As of 5PM ET, Canvas is still inaccessible for all US customers. We will continue to monitor this evening and share any updates as we receive them.

Please see Instructure's status page (https://status.instructure.com/) for the most up to date information on this outage.
Posted Oct 20, 2025 - 16:56 EDT

Update

Gradescope, iThenticate, Turnitin, and PollEverywhere are now working.

Canvas is still experiencing an outage. While Canvas is inaccessible, you can access these tools directly at Gradescope.com, iThenticate.com, Turnitin.com, and Polleverywhere.com.
Posted Oct 20, 2025 - 11:33 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:28 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:01 EDT

Identified

Several of our tools (including Canvas) are currently impacted by an ongoing Amazon Web Services (AWS) outage this morning.

You may be unable to login or encounter significant performance issues for Canvas, Gradescope, Poll Everywhere, and Turnitin until this is fixed by Amazon. You can follow the progress below for specific tools, and I'll update you once we hear that service has been restored.

Canvas: https://status.instructure.com/
Gradescope & Turnitin: https://turnitin.statuspage.io/incidents/h42fdjs6nzw3
Poll Everywhere: https://pollev-status.com/incidents/v32rtpj2qblt
Posted Oct 20, 2025 - 09:48 EDT
This incident affected: Canvas and Learning Tools (iThenticate, Poll Everywhere, Turnitin, Gradescope).